gjdwebserver-overlay/app-mobilephone/mobile-config-firefox/mobile-config-firefox-4.3.1.ebuild
2024-06-04 17:13:25 +02:00

25 lines
749 B
Bash

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="Mobile and privacy friendly configuration for Firefox"
HOMEPAGE="https://gitlab.com/postmarketOS/mobile-config-firefox"
SRC_URI="https://gitlab.com/postmarketOS/mobile-config-firefox/-/archive/${PV}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~arm64"
src_install() {
default
mv "${D}"/usr/lib "${D}"/usr/lib64 || die
}
pkg_postinst() {
elog "You will need to copy /etc/mobile-config-firefox/userChrome.css file to"
elog "your firefox profile's chrome folder ~/.mozilla/firefox/XXXX/chrome/ "
elog "to enable firefox mobile layout, you might need to create the chrome "
elog "folder if it's not there"
}